Can't enable Mac OSX Location Services with Safari

I just ran into a nasty problem while debugging, which I hope someone else ran into ... and solved. I was looking for an app that uses the javascript Geolocation app for OS X Lion. I am using Safari and everything works fine.

After restarting, Safari reported that access to Geolocation services was denied. In Safari preferences, under "Privacy", the option "Restrict access to websites for location services" in the setting is indeed set to "Deny without asking".

The problem is that I cannot enable this setting. According to the Apple doc, you first need to enable location services for the app in system settings. It's under Security & Privacy -> Privacy. I've seen cases where this is empty and Safari just doesn't show up. Finally, after another reboot, actually appeared here. Unfortunately, after enabling Safari here, I still couldn't enable location services in Safari preferences. It almost looks like the settings are out of sync with each other.

Any thoughts would be greatly appreciated!


source to share

1 answer

I just ran into the same problem but found a solution on the support forum.

Solution 1: In the "Set time to time zone automatically using current location" field under "Date and Time"> "Time Zone" my problem was fixed. It is possible that a previous preference left over from my Snow Leopard installation was causing the problem.

Solution 2: For me, I had to exit the iPhone simulator to enable this option.

The second solution got the trick, but maybe only because I tried it first and first.



All Articles