L (lowercase L) in bash terminal

vikram@vikram-Studio-XPS-1645:~/comp$ l
3rdParty/    que.ico     SE32.EXE   start.fgx  Supp/         WebResources/
autorun.inf  Readme.txt  START.EXE  start.fgz  Walkthrough/
vikram@vikram-Studio-XPS-1645:~/comp$ ls
3rdParty     que.ico     SE32.EXE   start.fgx  Supp         WebResources
autorun.inf  Readme.txt  START.EXE  start.fgz  Walkthrough


What is the difference between these two commands?

I tried $ which l

, but there is no way out.

There is also no result for $ man l


I also tried unsuccessfully to use it on Google.


source to share

4 answers


is probably an alias for something like ls -F

. The option -F

forces ls

you /

to add to directory names, *

to executable regular files, etc.

UPDATE: As per your comment l

has an alias ls -CF

. Single letter variants can be "included", therefore ls -CF

equivalent ls -C -F

. This option -C

forces the ls

display of records by columns. This is the default if it ls

thinks it is writing to the terminal; the option -C

does it this way unconditionally. ( ls -1

lists one entry per line, which is the default if ls

is * is not written to the terminal.)

type -a l

should show you how it is defined. It is probably set to $HOME/.bashrc


( $

is part of your shell prompt, not part of a command.)



As far as I know, there is no generic 'l' command that exists or even does what 'ls' does, why your results are for which l

and man l

are empty

Do you have something in your path called l

that possibly launches ls




To see if its alias is checking the ~ / .bashrc file

$sudo cat ~/.bashrc | grep 'alias l='
alias l='ls -CF'




the specific bash command for "ls".

ilia@Latitude-E6410:~$ mkdir ltest
ilia@Latitude-E6410:~$ cd ltest
ilia@Latitude-E6410:~/ltest$ echo 321 > 321.txt
ilia@Latitude-E6410:~/ltest$ echo 123 > 123.txt
ilia@Latitude-E6410:~/ltest$ ls
123.txt  321.txt
ilia@Latitude-E6410:~/ltest$ l
123.txt  321.txt
ilia@Latitude-E6410:~/ltest$ whereis ls
ls: /bin/ls /usr/share/man/man1/ls.1.gz
ilia@Latitude-E6410:~/ltest$ whereis asdasdasd #This command doesn't exists
ilia@Latitude-E6410:~/ltest$ whereis l #Results of "whereis l" and "whereis asdasdasd" are same
ilia@Latitude-E6410:~/ltest$ sh #Try "l" in sh
$ ls #"ls" is working
123.txt  321.txt
$ l #But "l" doesn't
sh: 2: l: not found




All Articles