Failed to start activemq as a service under windows 2008 r2

we are trying to run ActiveMQ as a service on windows 2008 r2 server but we get "error 1067" and in the log file we see this

FATAL | wrapper | 2012/03/12 16:34:54 | Critical error: wait for JVM process failed 
STATUS | wrapper | 2012/03/12 16:41:00 | --> Wrapper Started as Service 
STATUS | wrapper | 2012/03/12 16:41:00 | Launching a JVM... 
FATAL | wrapper | 2012/03/12 16:41:00 | Unable to execute Java command. Accesso negato. (0x5) 
FATAL | wrapper | 2012/03/12 16:41:00 | "C:\Program Files (x86)\Java\ 


"accesso negato" means "access denied" (Italian). The java path seems to be correct. We tried all of these combinations:

C:\Program Files (x86)\Java\jre6\bin
C:\Program Files (x86)\Java\jre7\bin
C:\Program Files (x86)\Java\jre7\jdk1.7.0_03\jre\bin


where the java * .exe executables are present (we installed JRE6, JRE7 and JDK; before trying JRE7 / JDK1.7, we only installed JRE6).

It seems that all permissions are assigned to folders, and in the ActiveMQ service property, we have given administrator rights (maximum rights). On the forum, we learned that the "berth" field was in the config file, but it didn't solve anything.

Does anyone know if something is wrong with the way we installed / launched ActiveMQ or is incompatible with our environment / operating system?


source to share

2 answers

Try running bat file (\ bin \ win32 \ activemq.bat) as administrator. If this works, then you have incorrectly set up the activeMQ service to run under an account that has administrator privileges.

Edit: You need a 64-bit wrapper (ActiveMQ only comes with 32-bit by default). Few options:

  • Download the latest 64-bit shell available from the website
  • Start the process via jsvc (see this blog post describing the process)
  • Update to the latest 5.6 ActiveMQ which supports this out of the box (the previous 2 entries were only for pre 5.6 releases

Hope this helps you!



I just ran into this problem. The problem for me was that RabbitMQ was also running as a service and was binding to the same port. Stopping RabbitMQ allowed ActiveMQ to start. I could also change the ports.

Run Wrapper.exe in a command window to see the error. If it is a port issue, you can run a command netstat -a -b

to find out what the port binding is.

Below are the answers to the question of how to change the port if necessary:

How to change the default port number for Activemq



All Articles