On Xcode 4.3.1 4E1019, the startup screen (Default.png, etc.) Has a white line (1 pt tall) at the bottom of the image at startup

It's odd. I have Default.png, Default-Landscape.png, Default-Portrait.png, and Default@2x.png.

The normal "default zoom animation" is where Default.png is scaled from the center of the screen "in". This happens with all iOS apps, so this is the time when you can actually see that white line at the bottom of the Default image. It's a 1 pt (or so) line going from left to right at the bottom of all my Default.pngs ( Default@2x.png , Default-Landscape.png, etc) ... This happens on both of my devices: "iPhone 4 "and" iPad 1 ". This does not happen on any of the machines.

The images haven't changed between my lines. Indeed, I built an earlier version last week (with the same starting graphics) and it didn't.

Images are correct size. I even changed .ipa to .zip uncompressed and looked in the package. Png is correct size so nothing was killed.

When I switch back to AdHoc from the last build of my application, the problem goes away. When I go to the current build, the problem comes back.

Any ideas?

BTW: Appendix: I grabbed my old source code (for the version which is ok), compiled with Xcode 4.3.1 and has the same problem. white line at the bottom of the startup screen.


Ok, ok we noticed:

Our PNGs for ipad were 1024x768 and 768x1024 instead of 1004x768 and 748x1024

We fixed that (strange that they worked before) and the iPad launch was fixed and displayed correctly. iPhone is still broken.

IOS Human Interface Guides / Icon and Image Creator Custom Tips Says iPhone Should Be 320x480 And 640x960

I must have been confused when I originally created the iPad graphics, but they worked up to XCode 4.3.1 !!! (2 years!) I know the iPad's dimensions were off, but wonder what caused Xcode to change this and decide that they were being cropped now?


source to share

2 answers

This is the same problem as: iOS 5.1: background color [UIColor colorWithPatternImage:] draws solid black

Basically: iOS 5.1 cannot decode the last row of pixels in an indexed color PNG (PNG8) or grayscale PNG.

A workaround is to use PNG32 or add dummy lines to the end of PNG8.

I filed a bug with Apple (# 11069678) and advised you to do the same :)



Photoshop users:

  • Use the Picture menu to change the mode to RGB.
  • Then use the Picture menu to switch to 16 bpc.


All Articles