Blend for visual studio 11 get error message

  • Installed Windows 8 Preview
  • Installed Visual Studio 2010 Premium
  • Installed Visual Studio 11 Ultimate

Everything was installed without errors.

I created a new Windows 8 Metro app using Visual Studio 11 and don't see any issues with the xaml view in VS 11 designer. If I view it in Blend For Visual Studio 11, the error is:

Failed to open TestApp.csproj project. The imported project "C: \ Program Files (x86) \ MSBuild \ Microsoft \ WindowsXaml \ v11 \ Microsoft.Windows.UI.Xaml.CSharp.Targets" was not found. Make sure the path in the declaration is correct and that the file exists on disk. c: \ Users \ testuser \ Documents \ Visual Studio 11 \ Projects \ TestApp \ testApp.csproj

Also if I create a Metro Metro style project (any of the templates) in Blend for Visual Studio 11, it shows an empty solution after it finishes. When I look in the directory where he assumed he created it, I only see the project files, not the solution.

Has anyone else had these problems?

Now the only question is how

- Comment 1 -

No, the path C: \ Program Files (x86) \ MSBuild \ Microsoft \ WindowsXaml ** v11 ** \ Microsoft.Windows.UI.Xaml.CSharp.Targets does not exist. Filesystem Path: C: \ Program Files (x86) \ MSBuild \ Microsoft \ WindowsXaml ** v11.0 ** \ Microsoft.Windows.UI.Xaml.CSharp.Targets

When I look at the project file, this is what I see:

<PropertyGroup Condition=" '$(VisualStudioVersion)' == '' ">
<Import Project="$(MSBuildExtensionsPath)\Microsoft\WindowsXaml\v$(VisualStudioVersion)\Microsoft.Windows.UI.Xaml.CSharp.targets" />


The project file seems to tell it the correct location, so I'm not sure why it is trying to find the wrong path?

- End of comment 1 -


source to share

1 answer

Try the workaround from the list of known issues: Blend cannot create projects for Metro style apps built using HTML when Visual Studio 2010 is installed after Visual Studio 11 Beta When Visual Studio 2010 is installed after Visual Studio 11 Beta, the installation changes the environment variable to a variable that is incompatible with Blend .

(in italics)

To fix this problem:

To work around this issue, follow these steps:

  • Right-click your computer and select Properties.
  • Click "Advanced Properties".
  • In the System Properties dialog box, Advanced tab, select Environment Variables. Environmental Variables
  • Under System Variables, click New.
  • In the Variable name box, enter: VisualStudioVersion.
  • In the Value field, enter: 11.0.
  • Click OK.

For Windows 8, to navigate to environment variables:

  • Finding additional system parameters
  • Make sure you have Settings selected on the right side.
  • Select the View advanced system settings option

Windows 8



All Articles