Failed to import openshift app into eclipse

I am using eclipse to connect with openshift.

Below are the steps I took.

  • register in openshift
  • created application "Application JBOSS Application Server 7"
  • uploaded by Eclipse Mars
  • loaded tools from the opening shift in the eclipse market
  • from the selected import options and select openshift
  • login to openshift from prompt (with default server location)
  • select "Use my existing application for unpacking" and in the "Browse" tab select the application I created in Down mode and click "Next"
  • in the next window select "create a new project" and click "Next"
  • in the "Configure Cloning" section, find the location where I want to clone my application.
  • on the same tab, clicked on "SSH Key Wizards" and a new SSH key is generated.
  • in SSH2 settings checked if my new key is present or not. (he was present).
  • click completed

displays cloning from ssh://<url>

and then it displays

Could not clone the repository. Authentication failed.
 Please make sure that you added your private key to the ssh preferences.
ssh:// Connection timed out: connect


I used these steps with several other ecplise options i.e. mars, indigo, luna, helio (none of them worked). I have used the above steps in all of them.

To see if the public keys are loaded on the remote server that checked and found that the public keys are loaded every time on the server.

Really stuck at this point.

I also have googled for other ways to do this, but none of them work for me, I think I am missing something.

I remember doing the same steps sometimes and it worked, but didn't work this time.

Please, help


source to share

1 answer

I found out that the port issue was the cause of this problem. At my university they use cyberoam and they blocked some ports that ssh was using to fetch data from remote. I just tried the same steps at home and it works as expected.



All Articles