Failed to start Sphinx searchd daemon due to already running search process and it restarts immediately after killing it

When I try to run searchd it gives the following error.

bind () failed, retry ...

FATAL: bind () failed Illegal search

I can find the searchd process with

root 14863 0.1 0.0 73884 3960? Ssl 23:21 0:00 / usr / bin / searchd --nodetach

Now when I kill it or try to stop it (searchd --stop), it restarts instantly.

root 15841 0.5 0.0 73884 3960? Ssl 23:33 0:00 / usr / bin / searchd --nodetach

I am assuming there are some settings with which it automatically starts when the process is not running. How can I stop this?


source to share

4 answers

By default, the debian package appears to start Sphinx with an additional keepalive process. I was able to successfully stop this;

sudo service sphinxsearch stop



"init: ... main process ended, respawning" assumes that there is something in the init script that sets a watchdog timer to make sure sphinx doesn't die.

Maybe you need to disable sphinx through the init script itself

/etc/init.d/sphinxsearch stop




As far as I know, Upstart is responsible for respawning searchd after trying to stop / kill it.

Since we know that this process is driven by an upstart, we can end the daemon with "stop sphinxsearch" and then start it again with "start sphinxsearch".

If you want to kill it as usual, like any other process, you can remove the "--nodetach" argument in the /etc/sphinxsearch/sphinx.conf configuration file. However, by doing this, you can no longer stop the process using "stop sphinxsearch".



No, there is no sphinx option to restart Sphinx. There is probably some monitoring tool installed for Sphinx like monit.



All Articles