Rails mysql server error "could not find gem"

When I try to start "rails server" in a new project, it returns

Could not find gem 'mysql2 (>= 0) X86-mingw32' in any of the gem sources listed in your Gemfile. 
Run 'bundle install' to install missing gems.


I ran 'bundle install' but I am getting the same error.

I already had mysql from the xampp package, but a friend of mine helped me install rails, so I'm not sure how he set it up. I am using Windows Vista.


source to share

4 answers

I ran into this problem a while ago while creating a RoR-dev environment on a windows machine. I had to copy the dll to the ruby ​​/ bin folder. View Public Profile Find all posts by ruby-forum http://www.ruby-forum.com/topic/150580



Try it gem install mysql2

. Then it should work.



I had a similar problem. For me, I needed to delete the old Gemfile.lock and allow it to be recreated by running a package update after I added the same version of mysql to the Gemfile that I installed via "gem install mysql".

This may or may not be the problem you were working with, but it looks like this error message -> "Unable to find gem" mysql ". For this reason can also be found.



I had a similar problem, but gem install mysql2

would give me an error when trying it can't find header files for ruby at ...


Running this fixed the problem for me: sudo apt-get install ruby-dev



All Articles