Eclipse plugin developed for Helios not showing up in Juno

I have developed a plug-in for Eclipse that works great in Helios. I installed Juno, put the flash module in the dropins folder and started Eclipse, but the plug-in doesn't work in Juno (my extra menu item is not showing).

When I browse the plugins, I see my plugin listed. I suppose it must be some kind of version issue ( something like this ), but when I created the plugin, I didn’t specify the maximum version, only the minimum versions.I noticed that it is not signed like the rest of the plugins. but I don't think it should stop it working.

So, I opened a plugin development project with Juno and tried to launch it via "Run Eclipse Application" under Testing. Same result (no menu item). I even removed the mine version (using the Properties ... button). There is no joy yet. When I do it with Helios, it works (menu item is displayed).

In my "Required Plugins" I have org.eclipse.ui, org.eclipse.core.runtime, org.eclipse.jdt.core, org.eclipse.core.resources, org.eclipse.ui. console, org.eclipse.jface.text, without any minimum or maximum versions . And the same entries are displayed when I click Show Plug-in Dependency Hierarchy. Everything seems to be in order, but my application doesn't seem to be working.

Plug-in Registry > (right click on my plugin) > Show Advanced

Plug-in Registry > (right click on my plugin) > Diagnose

results in No problems found.

Plug-in Registry > (right click on my plugin) > Start

results in a green triangle, but the menu item is still missing.

I even set up a feature update site; completely under Helios, I created a local feature update site, removed the jar file from the Helios drop-ins directory, and installed the app from the site. It worked great. But when I installed from Juno in the same way, it showed up in the plugin registry, but again, there is no menu entry. It seems to be found, just doesn't work (as can be seen from the missing menu item in the expected location).

In Extensions > org.ecliipse.ui.menus > menuContribution

I see my menu item there with locationURI=popup:org.eclipse.jdt.ui.PackageExplorer

. Something changed between Helios and Juno with this, maybe?

Update: . When setting an empty workspace it works. I installed a separate copy of Juno and pointed it to an empty workspace, then installed from the local feature updates site. As a result, the application behaved as usual. While this may provide a clue, it is not a "solution" because I have too many projects that need a lot of tricks and I shouldn't go that route.

Update2: 1) Was there a fresh install of Juno, open an empty workspace, closed Juno, and then specifies the contents eclipse\configuration\org.eclipse.equinox.simpleconfigurator\

and specifies the contents of the filesystem in eclipse\plugins

. The only difference between the two was that the entries end in .source

what is expected. 2) Started off Juno by pointing to a copy of my Helios workspace. Help > Install new software... > Add... > Local... > (select local feature update site) > (uncheck Group items by category)

and the others complete the installation successfully. 3) Closed Juno and noted that only my plugin was added to

and noted that only my plugin was added to the filesystem ateclipse\plugins

... In other words, they each had one additional element, which was my plugin. 4) Started Juno, but the menu item from my plugin was not showing, but all the readings (plugin diagnostics) indicated that it should work. 5) Copied the plugins stick to the folder folder, but it doesn't improve.

Any more advice on what to do next would be helpful .


source to share

1 answer

First you have to check if the plugin is found. Then you have to check if the plugin is allowed, i.e. if all requirements are met.

If you have the Eclipse plugin development version, you can open the plugin registry view. See if your plugin is on the list, if so, then at least it was found. Then right click on it, enable advanced operations and after that select diagnostics. Some of the requirements were probably not met. If you don't have a version of the Eclipse plugin, you can use the osgi console. Go to the console window and select OSGI console from the view menu. Run the command ss

to list all plugins, and diag 123

where the number is your plugin identifier, to diagnose it.

Also, see the previous answer to a similar question

I've had problems with getting plugins placed in the dropins directory to work at times ... you can try copying it into the directory directly. Or do it as if it should be handled; Create a site and an update site for it and install the plugin on the update site. eclipse/plugins

Edit: "In a blank workstation installation, it worked"

Oh right. You have problems with the file

. See this page :

The file contains a list of all plugins installed on the current system. At startup, all the plugins listed in this file are provided by OSGi as the exact set of plugins to run. Any additional plugins in the plugin directory or elsewhere are ignored.

Now check the workspaces in .metadata\.plugins\org.eclipse.pde.core\org.eclipse.equinox.simpleconfigurator

for the file. Compare files from two workspaces, the difference should be your file. Edit the file in your first workspace to contain your plugin line from from your second workspace.

The file can be updated, but manual changes are easier.



All Articles