No plugins found in the directory directory

What can cause Eclipse to ignore plugins in the dropins directory?

I created a dummyplugin based on the Eclipse wizard, exported it to a jar. When you drop it into the directories directory of a new Eclipse installation, it works great.

When I do the same, but in a custom Eclipse installation, it doesn't work. The plugin doesn't even show up in the plugin's registry view. No error messages or anything like that.

I tried:

  • Working with -clean
  • Working with -clean -consoleLog but no errors were printed
  • Running with -console and checking that the plugin is displayed with the ss command was out of luck.
  • Running with = C: \ Program \ Eclipse \ eclipse3.6 \ dropins \
  • Changing the name of the eclipse directory from eclipse3.6 to eclipse if I face the change Eclipse error
  • It's not due to dependency issues (like this question ) as the plugin wasn't even found
  • Update Copied eclipse.ini from working eclipse to normal, with the same result; Plugin not found. So the problem is not in the ini file.
  • Update. Thought the issue might be due to some permissions since I was not the owner of the custom installation. So I made a copy of the entire custom installation directory to make sure I am the full owner. Without changes
  • Update Starting with a new work area does not matter

Is it possible to determine that Eclipse should ignore the dropins directory? How?

The custom version of Eclipse defines many variables, but nothing like p2 or drop behavior.


source to share

2 answers

Pauses / Folder is the best effort, completely optional, silent no leftover. You do not know about the diagnosis, how you found it.

If you are using the director to set your package to your normal eclipse, at least you should be able to get an error message that will tell you what the problem is.

I suggest exporting your jar with minimal p2 metadata.

Then you use something like:

eclipse/eclipse \
-application org.eclipse.equinox.p2.director \
-noSplash \
-repository \
file://$HOME/eclipseUpdate \
-installIUs \


If p2 can't find any dependency, it should spew convoluted error messages that it can generate.



Hi @Fredrick I created my own plugin and I added to my eclipse like this:

  • Export the plugin as Deployable Plugins and Fragments . (Right Click on Plugin Project - Export - Plugin Development - Deployable Plugins and Fragments)

  • This will create a .jar file which you must copy to \ eclipse \ plugins

  • Restart eclipse.

I would say that everything will be.



All Articles