Cocos2D kazmath / kazmath.h file not found

In my application, I am upgrading from Cocos2D version 1.10-> 2.0-rc0a.

So I did everything right as far as I know, an issue that I think has to do with the user's title search path.

So my Cocos2D files are inside a folder inside a folder inside a folder inside , is on my desktop. So the actual cocos2D files contain 4 folders until they hit the desktop.

And my user title search path looks like this:



So the complete error is: vocabulary or preprocessor problem, file kazmath / kazmath.h was not found in CCNode.h. There are actually 4 , but they are identical.

Does anyone know how to fix this problem?



source to share

5 answers

Have you tried turning it off and on again?

Meaning: Check if the kazmath.h file is actually where it should be. If not, copy it accordingly the entire kazmath folder. It's not in the cocos2d folder, but in a separate "external" folder, so you may have missed it in your project.



A little workaround that worked for me.

I was using Xcode 4.5.1.

My project had cocos2d library included, after which I included kazmath library from external folder.

I've replaced all occurrences of "kazmath / kazmath.h" with "kazmath.h" and all "kazmath / GL / something.h" with "something.h". After that everything was built fine.



Be sure to include double quotes. something like "$ {SRCROOT} / TestProjet1 / libs / kazmath / include" (also with recursive option selected)



I had the same problem.

All you have to do is add the kazmath headers path to Build Settings> Headers Search Paths

e.g. lib / kazmath / include



Go to Build Settings, then Find Header Search Paths. Add the relative path to the kazmath folder.

"./lib/kazmath/include"   //Where . is project directory. 




All Articles