Ruby on Rails server error

I am not a full RoR developer (php developer mainly), I only have small projects / tutorials, but I inherited the rails project and although my environment mimics the heroku production environment, I have a problem in our local home environment. we are transferring the application to be placed in the house.

I ran bundle install

, and I have all the necessary gems, but I still get the occasional bug to: Could not find Ascii85-1.0.1 in any of the sources (Bundler::GemNotFound)

. I ran gem list

and the gem appeared, but the app won't work. the database connection seems to be correct, I'm just not sure what the problem is, any advice would be great - thanks in advance.

complete passenger / rail error is attached: enter image description here


source to share

3 answers

In more detail: The reason you are seeing this error is because something in your application is asking for Ascii85 code. It could be in your application code or one of its gems or plugins.

To see gem dependencies (i.e. what they need) and what they need:

$ gem dependency Ascii85 --reverse-dependencies
Gem Ascii85-1.0.1
  bundler (>= 1.0.0, development)
  rspec (>= 2.4.0, development)
  Used by
    pdf-reader-1.1.0 (Ascii85 (~> 1.0.0))


So a gem with a PDF reader is a possible problem. The results on your system may vary.

A look at the pdf reader:

$ gem dependency pdf-reader --reverse-dependencies
Gem pdf-reader-1.1.0
  Ascii85 (~> 1.0.0)
  ZenTest (~> 4.4.2, development)
  rake (>= 0, development)
  roodi (>= 0, development)
  rspec (~> 2.3, development)
  ruby-rc4 (>= 0)
  Used by
    prawn-0.12.0 (pdf-reader (>= 0.9.0))


So the shrimp gem needs a PDF reader that Ascii85 needs.

In Rails, from time to time, the author of the application or gem does not add all the dependencies to the Gemfile or install scripts.

This is usually a bug and easy to fix - you can fix it in your app by adding a gem, and ideally you can also contact the author to suggest a fix.

Sometimes there are reasons for a missing dependency, like code that needs to implement a method, but leaves it up to you, what gem to install to provide the method.

Hope it helps.



Just include the same gem in your Gemfile and install the package. In Gemfile, just enter the bottom line,

gem "Ascii85", "~> 1.0.1"


Try it. ' bundle install

' He will solve the problem.

Thank:) -




umask 0022


when running things like ... bundle install


bundle install --path vendor/bundle  




All Articles