Creating a MonoTouch Application

I was able to install a trial version of MonoTouch as I'm interested in buying a license, but want to try the product first. The problem I'm having is this:

  • I have installed MonoTouch and MonoDevelop

  • I downloaded Xcode which includes the iphone sdk.

When I open monodevelop and create a new iPhone app or project, it creates it and opens it in monodevelop. Stunning. when i try to compile and run in the simulator i get the error "iphone sdk not installed".

Now it might be because the xcode I downloaded from the Apple developer site is an application file i.e. no installation required, you extract the dmg file and then Xcode runs right from there and you can copy it from dmg directly to your disk and run it from there. is there any specific place where i have to put this file for monotouch to find it? how can i solve this?

Another problem: when opening a xib file in my project, it doesn't open the interface constructor in monodevelop, it opens the source code of the files. hopefully solving the xcode issue it takes care of this as well?

Using Macbook Pro OSX 10.7.3


source to share

3 answers

You are correct, the problem is that MonoDevelop cannot find Xcode.

The easiest way is to install Xcode from the AppStore. In this case, MonoDevelop will automatically detect the location.

You can also tell MonoDevelop where the SDK is in the MonoDevelop settings (remember to restart MonoDevelop):


Or you can copy to your application directory and MonoDevelop will find it automatically (if you have the latest version of MonoDevelop and Xcode 4.3 installed).



Have you tried starting Xcode and verified that it is installed? It might sound like a silly question, but when you download Xcode from the AppStore, you only download the installer, which you in turn must run to actually install Xcode.



I solved the problem. I downloaded another version of xcode which physically installed it on the computer, now everything works nicely.



All Articles