Could not find rails RubyGem (> = 0) (Gem :: LoadError)

I am creating a site using Ruby on Rails 3. I have been working on this project for 2 months now and everything is working fine. All of a sudden I get the following error after adding the gem 'ckeditor', '3.4.2.pre' to my gemfile. I followed the cceditor tutorial here: and everything worked fine, but since then whenever I run any command, for example a server or a set of rails packages on my console I am getting the following error:

WARNING:  Invalid .gemspec format in '/usr/lib/ruby/gems/1.8/specifications/arel-0.3.3.gemspec'
/usr/local/lib/site_ruby/1.8/rubygems.rb:777:in `report_activate_error': Could not find RubyGem rails (>= 0) (Gem::LoadError)
    from /usr/local/lib/site_ruby/1.8/rubygems.rb:211:in `activate'
    from /usr/local/lib/site_ruby/1.8/rubygems.rb:1056:in `gem'
    from /usr/bin/rails:18


I searched on google and got a solution saying running gem install bundler but that didn't solve my error. Due to this error, I cannot proceed further as no command is being executed.

How can I resolve this error? thanks in advance...


source to share

1 answer

I assume you are using ree version 1.8.7, a couple of gems does not support ree 1.8.7. Check the gem version that supports ree 1.8.7 and install the corresponding gem version. If you couldn't find a solution, please leave a comment



All Articles