Changed Launch10 = shell.exe to a different value ... now what?

I am running Windows CE 5 and before realizing that it was the wrong reg key, I changed the value of HKLM> init> Launch10 from shell.exe to my own program. Now I know that I had to change Launch50.

So, when my physical device boots up, I just get a blank screen, and since the shell is actually being used to communicate between the dev block and the device I cannot connect to it from my computer.

Thoughts / Ideas?

 - If there is a way to do a factory reset, I don't know that, the inside of the device is cutting off from me due to the security screws, the parts I can access do not provide me with any parameters.
 - No other applications to launch, although I expected some, so there is no way to launch anything. network communication and USB are not even included at the moment.
 - The platform usually has the ability to debug through ActiveSync, but it hasn't worked since I made the change. The remote registry is how I made the changes to begin with.
 - When I took out the batteries, there was a small plate that I was able to remove, which had a port, but I'm not familiar with the type. It looked much wider with more pins than a typical serial connection.
 - I tried to find out the connection with KITL, but I have no setup, not sure if it will work or not.
 - As far as I know, the OS is not on removable media, or if I can't tell and can't physically get to the media.

Now for the good news: the device supports the "Secure Boot" option that I was able to access. This boots the device into a smaller version of Windows CE so you can recover the system. However, the version is so limited that I cannot connect to it remotely. What can I do to change the image so it recreates the registry?

Solved I called the salesperson and they were able to show me where the registry hive is. I removed the hive and the OS booted. The only problem was that all installed apps stopped working / were no longer seen as installed. Luckily I have a few of these devices, so when I knew where the registry folder was, I just copied the files from working to dead and that fixed it.


source to share

1 answer

So, the OS no longer launches the shell - this can be problematic, depending on the capabilities of the device (which you told us a little about).

  • Can you restore the factory state? If so, it will change your change.
  • Can you get other applications to work (ie what platform is there a specific "launch" on) for the OEM? If so, you can run the application to restore this registry key
  • Does the platform have the ability to connect a debugger? Using a remote registry editor from the platform tools might be the way to restore it.
  • Is there a way to reboot the OS? It's tough, but may be the only way to restore it
  • Do you have a KITL connection option? You can use this to connect to instruments.
  • Can you change the OS image? This will invalidate the MD5 hash of the existing registry and force it to create a new one.
  • Is the OS itself on removable media? Plugging it into your PC and removing the registry hives will most likely recover.

If you don't have any of these at your disposal, you can be the proud owner of a new brick - contact the OEM and see if they can rebuild it for you.



All Articles