MSSQL error (if not enabled) using WAMP / PHP 5.3.4

I am getting the error:

"Fatal error: Throw" RuntimeException "with message 'Extension" mssql "not loaded" in ... "

Although it is included. In php.ini (PHP version 5.3.4) it has no results (not ;

) before extension=php_mssql.dll

and appears in the PHP extension options list in the system tray menu. What could be causing this?

Also related to gender, I cannot run php version 5.3.1. I downloaded and installed it, but when I switched to it in wamp, the wamp system will try to stay yellow (instead of white, indicating it is ready to go). And no php downloads anywhere / can get to localhost or phpmyadmin at all. I tried running 5.3.1 as working for this mssql error.

I am running WampServer version 2.1 on a 64-bit box with Windows 7. This same fine tuning works very well on my Windows XP (32-bit) box with 5.3.1.


source to share

1 answer

Same problem. My apache log shows

PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.4/ext/php_mssql.dll' - The specified module could not be found.\r\n in Unknown on line 0.


I have the same problem with the ZIP module. Modules do not legally exist.

I tried to upgrade to PHP 5.3.1 from but then my Apache didn't start at all; I am guessing this is an x64 / x86 issue.

Then tried to copy php_mssql.dll from 5.3.1 to my 5.3.4 directory and then restart apache and it was just more with error

PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.4/ext/php_mssql.dll' - %1 is not a valid Win32 application.


Installing WampServer 2.1e (active build), but 32-bit to see if there are any differences. There were. This creates PHP 5.3.5 packages that still don't contain php_mssql.dll. BUT I was then able to use PHP 5.3.1 which I downloaded (apparently it is capable with this WAMP build, whether it is 2.1e or because it is 32-bit, I don't know or care).

So the point in history is that if you are trying to use WAMP Server with the PHP MSSQL extension, you will need Wamp Server 2.1e (32-bit in particular) and PHP 5.3. 1 .

Also note that I still cannot get the ZIP extension working with this setting, but luckily it is not essential to me for my current project.

Hope this helps someone.



All Articles