TFS mapping passed in solution explorer but is correct in Team Explorer

I have a team project that I was working on, but today I opened Visual Studio 2013 (update 2) and my solution, just to see that the TFS options (register, get the latest menu options, and lock and + signs next to files ) disappeared. The solution is similar to a local solution. I did nothing. When I go to the command options, I see that it is mapped to the correct path and I am in the correct workspace. I removed the mapping, removed the solution locally (I had no pending changes), and reassigned the solution from TFS. I got the latest version but still no mapping in the solution explorer. Restart Visual Studio many times (obviously) to no avail. However, I can get the latest information from the team browser. What could be the cause and how can I fix this problem?


source to share

4 answers

You need to open "File | Source Control | Change Bindings". If the files are in the correct folder, you should see a bunch of red squiggles under the mappings.

  • Link all projects and solution
  • Cancel all projects and solution

This should fix the problem.



You may have lost bindings to the solution Try bind to the original control. Also check that you are in the correct workspace in both locations and that you are mapped correctly.



Your top source location is mapped to your local folder, check it and delete if mapped to your local folder.

Right Click -> Advanced -> Remove Mapping




I went to Control Panel -> User Accounts -> Credential Manager and removed several links to the service account, some of which became associated with my workplace over the weekend. Not sure why this happened, but removing those associations and restarting visual studio solved the problem.

Due to this issue, the following issues arose:

  • Not enough memory warning when running an existing solution that has always worked fine.
  • When "get latest" in a solution, I get an error when our service account does not have sufficient permissions to perform an action on my own workspace.


All Articles