Errors with cabal on Windows with latest Haskell framework (2014.2.0.0)

I cannot use cabal with the latest Haskell framework (2014.2.0.0). I tried to delete by removing all folders from PATH and deleting the cabal library directory and so far no luck

When I run cabal

from the command line in the MINGW32 GitBash shell, I get the following error:

cabal.exe init
cabal.exe: The program ghc version    =6.4 is required but it could not be


( cabal configure

, cabal install

etc. all give the same error except cabal --version


Now when I execute cabal from windows cmd it works fine, but when I try to do cabal init

I get this:

>cabal init
Package name? [default: toyrsa]
Package version? [default:]
Please choose a license:
* 1) (none)
  2) GPL-2
  3) GPL-3
  4) LGPL-2.1
  5) LGPL-3
  6) AGPL-3
  7) BSD3
  8) MIT
  9) Apache-2.0
 10) PublicDomain
 11) AllRightsReserved
 12) Other (specify)
Your choice? [default: (none)] 3
cabal: git: does not exist


Choosing the default options or other options gives the same result. Moving to Cabal 1.20 doesn't help either.


source to share

2 answers

This bug has been documented here: and claims to be fixed in the 1.20 series. If you are using 1.20 and still working with it (and make sure you are using 1.20 and not an older binary in your path), you should definitely report this and reopen the ticket.



Running cabal initialization from cmd can be made to work by adding git to your PATH. Then the error in step 3 goes away. It still seems rather odd that I need to git create a config file for an empty local project with no dependencies.



All Articles