How do I install postgis 1.5 on ubuntu 14.04?

The problem is my project is using old versions of postgres and postgis. On 13.04 I just downloaded the deb package and installed it, but it looks like something changed in 14.04 and the package didn't seem to resolve any of that dependency.

Do you have any idea how to fix this?


source to share

1 answer

Note that PostGIS 1.5 is supported for PostgreSQL 8.3 through 9.2 , but the default installation for Ubuntu 14.04 is PostgreSQL 9.3 , so you need to install an older version.

I suggest installing PostgreSQL 9.2 from the PGDG APT repo , which is carefully maintained.

After installing an older version of PostgreSQL, you will probably need to build PostGIS 1.5 from source. Below are the guidelines:

sudo apt-get install build-essential libgeos-c1 libproj-dev libjson-c-dev libxml2-dev libxml2-utils xsltproc docbook-xsl docbook-mathml


And download, setup, build and install:

tar xfvz postgis-1.5.8.tar.gz
cd postgis-1.5.8
sudo make install
sudo ldconfig


Also see these build instructions for older version of Ubuntu .



All Articles