Css.map not found with gulp-ruby-sass

I have an app.scss file that is compiled to CSS with gulp-ruby-sass fine, the problem is that in my console I always have this error:

GET http://localhost:8100/css/app.css.map 404 (Not Found) 


I'm not sure take care of looking at the pre-rendered file when checked in the browser (I find rendered CSS better at catching errors). I want this error message to go away.

I am using Gulp to build an application, and for the purposes of this question, that means files are moved from one folder to another for serving.

I tried to create it with

sass css/app.scss:css/somethingelse.css --sourcemap


But it just resulted in:

DEPRECATION WARNING: Passing --sourcemap without a value is deprecated.
Sourcemaps are now generated by default, so this flag has no effect.


At the bottom of my CSS rendering, I have this comment:

/*# sourceMappingURL=app.css.map */


My build file contains the following:

gulp.task('styles', function() {
  gulp.src([appDir + '/www/css/*.css', './commons/styles/main.scss', appDir + '/www/css/*.scss'])
    .pipe(plugins.rubySass({style: 'expanded'}))
    .pipe(plugins.autoprefixer('last 1 version'))
    .pipe(gulp.dest(buildDir + '/www/css'));


I also tried adding sourcemap: "none" to rubySass constructor.

Any idea what is causing this?


source to share

2 answers

Something is wrong with gulp-ruby-sass. Instead of using

sourcemap: none



"sourcemap=none": true


disable source files

I tried to fix the "Unknown word" error myself .




By default, the sourcemap

gulp-ruby-sass parameter is set to auto

. In your task, sass

you must set it to none

so that this additional comment is not added to your generated .css file, resulting in a 404 error.

.pipe(sass({ sourcemap: none }))




All Articles