Could not load file or assembly 'Microsoft.SqlServer.Types, Version =

I started working on my application, which I have not touched for about a month, and when I run the application and try to save the changes, I get the following error:

Could not load file or assembly 'Microsoft.SqlServer.Types, Version =, Culture = neutral, PublicKeyToken = 89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified. ":" Microsoft.SqlServer.Types, Version =, Culture = neutral, PublicKeyToken = 89845dcd8080cc91 "} System.Exception {System.IO.FileNotFoundException}

I have no idea why this error is suddenly popping up because the last time I ran this application I never encountered this problem, so I don’t understand where this is coming from. This happens in the Context SaveChanges event, but when the error appears, I can press the start button again and it will continue as if nothing happened. After that, all subsequent save attempts will work without showing an error, but if I restart the application it reappears. My application is a Windows Form application using the .NET Framework and Entity Framework 4 and the database is Sql Server 2005. Any thoughts on what might be causing this issue?



source to share

All Articles