JMS TextMessage - not working after deploying to WebLogic

I got a weird problem after migrating my application from OC4J server to WebLogic 10.3.6 server.

My application creates a JMS TextMessage on the OracleAQ queue. It worked fine. But after deploying the application to WebLogic, the received text messages are stored in the USER_DATA_TEXT_LOB

(clob) column instead of the USER_DATA_TEXT_VC

(varchar2) column in the underlying queue, whereas USER_DATA_TEXT_LEN

this is very less (less than 1,000 characters).

As a consequence, consumer application does not remove the message and throws an error: Payload is NULL


Appreciate any help in this regard.


I have tried using jms BytesMessage and it works as expected.


source to share

1 answer

I suspect that this is due to the fact that the version aqapi.jar

and ojdbc.jar

not the same servers OC4J

and weblogic


Try replacing these jar files from your OC4J with your weblog.

Some version will change the type to 500

chars, while the other will switch to 4000

. I'm not sure which version this is tho, but if the first one worked, you can try switching the jar files.



All Articles