Invalid CocoaTouch framework resource directory

I'm trying to compile a basic Cocoa Touch framework to test this new feature in iOS 8, but I'm running into some problems. First of all, the framework does not import any other frameworks or libraries, and the deployment target is set to iOS 8 (normal project when trying to create a Cocoa Touch framework. I added two methods:
 - addValue: toValue
 - subtractValue: fromValue

Compiling the framework goes smoothly if I don't try to sign it. When I import the framework into my TestFramework project and I press build, I get this as a build result: I am facing an unusual error that doesn't seem to affect anyone on the internet because no one has complained about this error yet. The error is as follows:

Warning: usage of --preserve-metadata with option "resource-rules" (deprecated in Mac OS X >= 10.10)!
.../DerivedData/TestFramework-ethagmafcjzncuftipguwzdeiezh/Build/Products/Debug-iphoneos/ replacing existing signature
.../DerivedData/TestFramework-ethagmafcjzncuftipguwzdeiezh/Build/Products/Debug-iphoneos/ invalid resource directory (directory or signature have been modified)


I mentioned that this "invalid resource directory" is a known issue for MAC developers, but I cannot find the correct solution. Who can point me in the right direction?

EDIT: I found out that it definitely has to do with code signing. I probably need to encode the frame sign, but this is not possible because I ran into the same error.


source to share

All Articles