Xcode 6: "Simulator in Use" error shows the simulator is NOT in use

With the new Xcode 6, sometimes when I switch between simulators I get the error "Simulator in Use - the simulator does not start because it is already in use." However, the simulator is NOT in use - and I cannot see it in the activity monitor. The only way to overcome this is to sign out and re-sign in Xcode.

Has anyone found an easier way to overcome this annoying error?


source to share

3 answers

Yes, I have experienced similar.

I basically do what you do - exit and re-enter Xcode.

I found that when you stop the simulator, don't start it / switch to another and start it up as quickly. Give a second or two before starting to avoid the problem (in my case) 90%.

This is not the case only for Xcode 6, in earlier versions this problem also occurred when you stopped and executed very quickly.



I ran into this problem so many times that you just closed and reopened Xcode

. That's for sure. Make sure the other Xcode

doesn't work. If you have multiple Xcodes, quit them.



I understand it. You don't need to close Xcode for this. I explain everything in detail.

Follow this answer:

Simulator in use - Solved



All Articles