Android systrace not working

I am using Systrace to analyze the performance of an application.

I have tried the following command,

python --time=10 -o mynewtrace.html sched gfx view wm  


But getting the following error,

E:\sdk\android-sdk\platform-tools\systrace>python --time=10 -o mynew
trace.html sched gfx view wm
Traceback (most recent call last):
  File "", line 286, in <module>
  File "", line 60, in main
    device_sdk_version = get_device_sdk_version()
  File "", line 44, in get_device_sdk_version
  File "E:\sdk\android-sdk\platform-tools\systrace\lib\", line 710,
 in __init__
    errread, errwrite)
  File "E:\sdk\android-sdk\platform-tools\systrace\lib\", line 958,
 in _execute_child
WindowsError: [Error 2] The system cannot find the file specified    


I am using Kitkat on a Moto e device with python 2.7 .


source to share

2 answers

I solved this (or very similar) problem by adding Android SDK tools to PATH. Don't forget to include the following variables in your PATH variable:



Also, there are many similar threads for this already on stackoverflow.



Try to update the SDK version for the platform, it worked for me.



All Articles