IntelliJ: tests not running

I run many JUnit tests in parallel and I often get results along the lines of "N tests passed, M tests failed, P tests did not start" (as opposed to this question , where tests do not start at all).

What could be causing this? I tried the "invalid cache" option however it doesn't seem to solve anything. I should mention that tests take longer than regular JUnit tests (they can take up to 90 seconds), could this have anything to do with that? Right now I just hit "re-fail tests" until I got IntelliJ to run all of them, which is pretty cumbersome. I am not posting anything weird to System.out, and as I said, I get them to run eventually.

It runs tests for about ten minutes and then no further tests run. Is there some kind of timeout somewhere that I cannot find?

Sometimes this appears on the console after this:

Process finished with exit code 255


Version Details:

  • IntelliJ version 13.1.4
  • JUnit 4.10

source to share

1 answer

There is an annotation timeout option @Test

- have you tried increasing it?

And also there is an option @Rule

and Timeout


Information about the time-out for a test - I hope this is true?



All Articles