Failed to start titanium appcelerator on IOS8

I am using the latest studio version

Titanium Studio, build:, Mac OS Version 10.9.5, alloy version 1.5.1, Titanium SDK version is 3.4.0.GA

I want to update my application to IOS8 which was previously developed in IOS7 using titanium, But I cannot work, I am getting the following error:

[ERROR] :  2014-10-07 10:14:04.018 xcodebuild[27236:5403]  DeveloperPortal: Using pre-existing     current store at URL (file:///Users/arunkumar/Library/Developer/Xcode/DeveloperPortal%206.0.1.db).
[ERROR] :  The following build commands failed:
[ERROR] :   Ld build/Debug-iphonesimulator/My\\ App normal i386
[ERROR] :  (1 failure)'


I also updated my xcode to the latest version (6.0.1), I can run an empty project, but I cannot find what is wrong with my application, please help me find a solution Thanks in advance


source to share

1 answer

This is a module conflict.

  • Try to remove modules one by one to identify the conflicting module.
  • Update the module.
  • If the updated Titanium SDK module did not install the previous SDK version

More details

I installed Titanium Studio for the first time. Got exactly this error. Failed to run it in iOS simulator. This is what I did.

  • Removing modules one by one and attempting to start. I found that the module

    was the culprit. Tried to work with all different versions. [cm. Photo]

  • Trying to install a new version

    . For this I needed to installgitto

    sudo npm install -g gittio

    then install

    gittio install

    it turned out that there is no distributable available

  • Install the previous version of the Titanium SDK. The previous app was built with 3.4.0. My SDK was 3.5.1GA. So I tried to install 3.4.0 with

    ti sdk install 

    Alternatively, you can install the SDK from the Titanium Studio help menu.

    Help >> Install Titanium SDK >> ... 

    Then select SDK 3.4.0 in SDK Titanium (see picture)

enter image description here



All Articles