VS 2013 Schemes Compare Without Updating Target

I have a database project on VS 2013 carried over from 2010 and when I compare the schema to the original database and target the DB project without refreshing the project after clicking refresh button. I tried this several times but didn't work. Do you have any clues?


source to share

2 answers

I had the same problem and Fisseha commented on another answer that really helped me.

Sorry I am no longer working on this project. But I remember it had something to do with setting -> app area -> check / uncheck permission. I have no idea why. - Fisseha Apr 23 '15 at 15:57

By disabling the permissions window in the settings area -> application area, it was able to trigger an update in the data project itself.



I had a problem too. I just experienced it on my car.

This was the moment when the original SQL Server instance was referenced by a server alias , ours is something like WorkplaceDev, which points to a local instance to my machine. When I configured the schema comparison using WorkplaceDev \ DatabaseName, the schema comparison showed the changes, but did not update the assignment.

Then I tried again to directly reference the database on my machine (JimsMachine \ DatabaseName) and it worked without issue.

Wish I am a little late to the party, but can you figure out if this matters?



All Articles