VSTest error on disk on every test

I have my own unit test project in Visual Studio 2013 that has been testing C ++ library development for many months now. Due to being nowhere to be found, Visual Studio started popping up the following message box whenever a test asserts:

vstest.executionengine.x86.exe - No Disk:
There is no disk in the drive. Please insert a disk into drive F:.


There are several tests that access the filesystem, but I've commented them out. I tried redoing the entire test project from scratch, but it still happens. Even a simple statement like this will result in a message box:



What causes this behavior?


source to share

2 answers

I would try running VS installation in recovery mode - maybe some of the vstest executables are gone and vs is trying to find them on the F installation drive



Definitely not a setup repair problem in my case. This only started to happen after I plugged in a new USB drive during testing.

Rebooting the machine solved the problem.



All Articles