Gitlab SSH key issue cloning a project

I am very new to using GIT. I know the basics of add, commit, push and pull.

My command project is hosted on gitlab. I created my SSH public key at work so that we can work together on the project.
We tried to work from home, so I set up another SSH key, I can clone the project. I have configured the SSH key correctly (I made sure of this ... it says I have two SSH keys stored in gitlab), but I get this message when I run the command git clone

... I have full access to the repository. .. I am registered as the owner. I think maybe there is a problem with my mac. Maybe I haven't configured anything?

ryans-imac:~ ryanchampin$ git clone
Cloning into ‘acr-booth’…
ssh: connect to host port 22: Operation timed out
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.



source to share

1 answer

First check if your GitLab server has been configured successfully by running this command from the installation directory: bundle exec rake gitlab:check

Then you should try to install gitlab-shell

by running the following command:bundle exec rake gitlab:shell:setup



All Articles