Links libTogl undefined

I am trying to install netgen (build from source). Therefore Togl is needed and I installed it via

sudo apt-get install libtogl1 libtogl-dev


When I type "make" I get the following error messages:

/usr/lib/gcc/x86_64-linux-gnu/4.8/../../../../lib/ undefined reference to `Tk_InitStubs'
/usr/lib/gcc/x86_64-linux-gnu/4.8/../../../../lib/ undefined reference to `tkStubsPtr'
/usr/lib/gcc/x86_64-linux-gnu/4.8/../../../../lib/ undefined reference to `Tcl_InitStubs'
/usr/lib/gcc/x86_64-linux-gnu/4.8/../../../../lib/ undefined reference to `tclStubsPtr'


The Togl may not have been set correctly. Is it 32-bit 64-bit emission? What should I do to fix this?


source to share

1 answer

This is an issue with referencing the correct Tcl and Tk versions as @keltar mentioned. If your goal is to build Netgen from source, your best bet is to stick with netgen-5.3.1 , which works with tcl8.5 and tk8.5 .

I ran into this problem because when I ran sudo apt-get install tcl-dev tk-dev

apt-get got tcl8.6 and tk8.6 for me. (If you search the web for these questions, you can see that these binding issues can sometimes be fixed by updating the Tcl / Tk version.) I removed the default tcl-dev and tk-dev packages and installed tcl8.5-dev and tk8. 5-dev.

Once you have a suitable Tcl / Tk version, you can install Netgen from source. For example,

./configure --with-tclconfig=/usr/lib/tcl8.5/ --with-tkconfig=/usr/lib/tk8.5/
make install




All Articles