Why doesn't Tortoise SVN show Commit option in some folders on my local machine?

This might be a silly question. I've started using Tortoise SVN since last month. I checked out a few folders from the repository and they are fine. When I right click on them I can see commit, validation and other options ...

But I wanted to push something to the repo. I couldn't see the commit option, so I played around with it, googled and did the import. The folder has been moved to the repo. Now, for all the folders that I checked out from the repo, I see a red exclamation or right-hand mark. But this one I pushed has no such indication. Also, there is no option called commit when I right click on it. Why is this? Am I doing something wrong?


source to share

5 answers

"Import" does not actually create a working copy. "Import" only adds files in the specified directory to the location in the repository. It does NOT convert the specified directory to a working copy or link it in any way to the repository server.

For now, your best bet is to select the svn checkout

imported directory to a new location and move all modified files from the directory where you imported.

To avoid future problems, instead of doing "imports", try creating a new directory in the repository, then create svn checkout

that empty directory to get a working copy, and then svn add

whatever files you want into that empty directory, then create svn commit




Is your directory added to SVN? (Must be if import worked)

When you right-click on the directory and select properties, do you see the Subversion tab?

You can also check the SVN log to see if there is a commit when importing files (import = add + commit)

If you don't see the commit of the files you want to push, you can add and commit them.



I think you could set options / properties.

Navigation: TortoiseSVN-->General-->ContextMenu

Here you will find the option "Donot show context menu for next path".

You need to clear all paths so that u can commit the code.

The second option is you can still copy the code from its parent directory.



If you don't see any SVN operations in the folder. Please check below step

Check if your workspace has a .svn folder which is a hidden folder..svn folder plays an important role in committing changes to the server

Open Hidden Folder Go to Setting -> Folder Options -> View -> Show Hidden Files, Folders ...

If you can't find the .svn folder, then you could export the code from the server, which you can't commit with any files.



For the sync folder, I forgot to copy the hidden ".svn" folder to the root directory when moving folders to sync. Once I did that, everything worked fine.



All Articles