Emacs can't load swi-prolog using default prologue mode?

My Gnu Emacs 24.4 on Win 8 doesn't seem to work with it by default. I have the latest version of SWI Prolog.

When I load Gnu Emacs and enter Mx prologue mode, the syntax is highlighted. However, I cannot compile the rules or do anything with them. When I try to run the prologue from Emacs with Cc RET, it says "Search for program: no such file or directory, prologue."


source to share

2 answers

The error message says that Emacs could not find an executable named prolog

in load-path

. So presumably the problem is that you didn't put your SWI-Prolog installation in yours $PATH


An alternative to setting $ PATH in your environment (or load-path

in ~/.emacs

) is to install prolog-program-name

in ~/.emacs




Would you like to take cmsc330? Anyway, if you don't agree with Emacs, Eclipse has a plugin for SWI, and it autocompletes as well. I would just use eclipse.



All Articles