Wrap table cell text in exported Excel in BIRT

I am using BIRT 4.4.1 in eclipse for generating reports.

I would like to wrap my table header text, it works fine in webviewer, but when I exported to succeed, the table cell text is on one line and also the text is overflowing. I don't want the cell width to be equal to the content, I would like to wrap the text based on its container width.

I have set cell width and label property to auto. is this correct or what am I doing to get it to work in the exported Excel report?

In Webview

enter image description here

After export, Excel view

enter image description here


source to share

1 answer

In 4.4.2 export as XLS (not xlsx). As a workaround, you can also add a string return to the text and which will display correctly when exported to xlsx.

The third option, which works with xlsx output, is to select the text box in the cell, and in General Properties, set it to Space for formatting. Then either set the header cell size to the height that covers the text you want, or in the general properties of the whole report, set the layout to auto layout.



All Articles