Vagrant / puphpet default: Box "puphpet / debian75-x64" not found

I'm new to Vagrant and I used PuPHPet to create a vagrant file, but when I do the vagrant command, I get this error:

Ξ» vagrant up

Bringing machine 'default' up with 'virtualbox' provider...
==> default: Box 'puphpet/debian75-x64' could not be found. Attempting to find and install...
default: Box Provider: virtualbox
default: Box Version: >= 0
The box '["puphpet/debian75-x64"]' could not be found or
could not be accessed in the remote catalog. If this is a private
box on HashiCorp Atlas, please verify you're logged in via
`vagrant login`. Also, please double-check the name. The expanded
URL and error message are shown below:

URL: [""]
Error: SSL certificate problem: unable to get local issuer certificate
More details here:

curl performs SSL certificate verification by default, using a "bundle"
 of Certificate Authority (CA) public keys (CA certs). If the default
 bundle file isn't adequate, you can specify an alternate file
 using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
 the bundle, the certificate verification probably failed due to a
 problem with the certificate (it might be expired, or the name might
 not match the domain name in the URL).
If you'd like to turn off curl verification of the certificate, use
 the -k (or --insecure) option.



source to share

1 answer

If you are using an older version of Vagrant then the certificate package in the package may be corrupted. This seems to have been fixed in 1.7.2.If for some reason you must be tied to an older version of Vagrant or you still have problems with an updated version of Vagrant, you can either copy your ca-certificates.crt to Vagrant cacert .pem with:

cat /etc/ssl/certs/ca-certificates.crt >> /opt/vagrant/embedded/cacert.pem


Or you can tell Vagrant not to worry about the certificate chain being broken by adding the following line to the Vagrantfile :

config.vm.box_download_insecure = true


or by specifying the --insecure

variant vagrant box add

as follows:

vagrant box add --insecure puphpet/debian75-x64




All Articles