ERR! net. Can't install latest npm, yoman, bower and grunt

I have an installation problem for yoman, gazebo, grunt and the latest npm.

The latest version of NodeJS (0.12.2) is installed on my computer. I have npm version 2.7.4, but when I run git bash in nodejs folder and type "npm install npm" or "npm install npm @latest" then the error message appears:

error Windows_NT 6.1.7601
error argv "c:\\Program Files\\nodejs\\node.exe" "c:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "npm@latest"
error node v0.12.2
error npm  v2.7.4
error code ETIMEDOUT
error errno ETIMEDOUT
error syscall connect
error network connect ETIMEDOUT
error network This is most likely not a problem with npm itself
error network and is related to network connectivity.
error network In most cases you are behind a proxy or have bad network settings.
error network
error network If you are behind a proxy, please make sure that the
error network 'proxy' config is set properly.  See: 'npm help config'
verbose exit [ 1, true ]


And the complete debug log:

0 info it worked if it ends with ok
1 verbose cli [ 'c:\\Program Files\\nodejs\\node.exe',
1 verbose cli   'c:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli   'install',
1 verbose cli   'npm@latest' ]
2 info using npm@2.7.4
3 info using node@v0.12.2
4 warn package.json nodejs@0.12.2 No description
5 warn package.json nodejs@0.12.2 No repository field.
6 warn package.json nodejs@0.12.2 No README data
7 silly cache add args [ 'npm@latest', null ]
8 verbose cache add spec npm@latest
9 silly cache add parsed spec { raw: 'npm@latest',
9 silly cache add   scope: null,
9 silly cache add   name: 'npm',
9 silly cache add   rawSpec: 'latest',
9 silly cache add   spec: 'latest',
9 silly cache add   type: 'tag' }
10 verbose addNamed npm@latest
11 silly addNamed semver.valid null
12 silly addNamed semver.validRange null
13 info addNameTag [ 'npm', 'latest' ]
14 silly mapToRegistry name npm
15 silly mapToRegistry using default registry
16 silly mapToRegistry registry
17 silly mapToRegistry uri
18 verbose addNameTag registry: not in flight; fetching
19 verbose request uri
20 verbose request no auth needed
21 info attempt registry request try #1 at 09:30:04
22 verbose request id 6fa6dc64e92e52cc
23 http request GET
24 info retry will retry, error on last attempt: Error: connect ETIMEDOUT
25 info attempt registry request try #2 at 09:30:35
26 http request GET
27 info retry will retry, error on last attempt: Error: connect ETIMEDOUT
28 info attempt registry request try #3 at 09:31:56
29 http request GET
30 verbose stack Error: connect ETIMEDOUT
30 verbose stack     at exports._errnoException (util.js:746:11)
30 verbose stack     at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1000:19)
31 verbose cwd c:\Program Files\nodejs


I read several threads with nodejs issues and found a way to install http proxy. Is this a solution?


source to share

1 answer

I solved my problem. To find out the name of my proxy server in Windows 7, I opened a windows command prompt and typed:netsh winhttp show proxy

Then I added these lines to the .npmrc data (path: C: \ users \ username)



It works great :)



All Articles