Failed to validate WatchKit code signature

I'm trying to start the WatchKit app on Apple Watch, but every time this message tells me it can't verify the code signature:

companionappd[153] <Warning>: failed to install WatchKit application, error: (Error Domain=LaunchServicesError Code=0 "The operation couldn’t be completed. (LaunchServicesError error 0.)" 
UserInfo=0x15ddfba0 {Error=ApplicationVerificationFailed, 
ErrorDescription=Failed to verify code signature of <MIExecutableBundle : 
path = /private/var/mobile/Library/Caches/**.** 
identifier = com.**.**.watchkitapp type = 4> : 0xe8008019 
(Application signature not valid)})


But I tried to revoke my current developer certificate, created a new provisioning profile for the app, WatchKit extension and WatchKit app. I also placed the Apple Watch Device ID in this provisioning profile.

I deleted all provisioning profiles on my mac, rebooted it.

I cleaned up the project, deleted derived data.

I have restarted my mac.

I did this: stackoverflow

and this: stackoverflow question/97885 / ...

I did everything!

Does anyone have the same problem and find a solution? My next step is to do a clean install of the Mac, iPhone and Apple Watch. But I would like to find another solution! :)



source to share

1 answer

I removed the watchkit target (extension and app) and created a new one, now it works ...


I found that it is one of my script runs (I don't know which one) that is causing the problem. These scripts are where on the target Apple Watch. Now my scripts remain in the main target application!



All Articles