Compiler error after adding new configuration to project

I ran into a problem after setting a new value for config on build (after reading the following post: Different app icons for your iOS beta, Dev and Release build ). The error message looks like this:

ld: file not found: /Users/.../Library/Developer/Xcode/DerivedData/SomeAppName -... / Build / Products / Debug-iphoneos / / SomeAppName

clang: error: linker command worked with exit code 1 (use -v to see Call)

I am not sure how to fix it, check and double check it with the article, and I did everything as described.

Edit: the error comes from the target


source to share

2 answers

Managed to find the answer: / ...

I solved it in Xcode 6 very simply:

  • Select a project in the project navigator.
  • Select Test Tests by Purpose
  • General tab change host application from dropdown
  • Build and run.

This problem happened to me because I renamed my project and the tests could no longer find it. - Yowza7



Deleting the testing target didn't work for me.

I posted a solution that actually worked here: New XCode Configuration and Scheme Created - The linker crashed unexpectedly

This basically means that Xcode is looking for libraries built with the Release configuration.



All Articles