Kvm virtual machine error

I am trying to run sroid sdk emulator on Ubuntu 14.04 with AMD A6-3670 processor and I am getting the error

/home/jeff/Android/Sdk/tools/emulator -avd Nexus_5_API_22_x86 -netspeed full -netdelay none -qemu -m 512 -enable-kvm
ko:/home/jeff/Android/Sdk/tools/emulator64-arm: invalid option -- '-enable-kvm'


I am a complete newbie when it comes to virtual machines.

Can anyone tell me what this means and give me some pointers to create it?

PS: kvm is loaded and I seem to be a member of kvm

jeff@Snowdon:~$ sudo addgroup `whoami` kvm
The user `jeff' is already a member of `kvm'.



source to share

1 answer

kvm is basically an optimization that allows virtual guest binaries to run directly on the main CPU without translation. You have an x86_64 processor (AMD) and are trying to run an ARM emulator, so kvm won't help. Kvm only works when the guest VM and CPU have the same instruction set.

Just leave the kvm parameter. Qemu can emulate ARM binaries on x86_64 processor. It won't be as fast as kvm.



All Articles