Texmaker does not update PDF viewer

I created a bash file that compiles my latex file constantly, the problem is that the PDFviewer in texmaker is not updating, the original PDF file is updated. Why does PDFviewer keep showing the old PDF until I use Texmaker to compile texmaker? ... I want the built-in PDFviewer in texmaker to update, it shows in the PDF, even though I'm not using texmaker to compile the .tex file.

Bash file.

while true
    pdflatex -synctex=1 -interaction=nonstopmode /Users/Johnathan/Documents/Bachelor/Rp/bachelor.tex
    sleep 4



source to share

3 answers

I think the problem is not your script (this works for me), I think of your PDF reader.

1) Try to use Evince as a PDF reader, it will update your pdf file automatically. It has versions for Windows and Linux and it is free.


2) Another way to use your web browser (I used Mozilla) as a PDF reader by writing in the url bar:

File: ///Users/Johnathan/Documents/Bachelor/Rp/bachelor.pdf

but this second way is that you have to update your web browser yourself.

I hope this helps!



I had the same problem that the PDF viewer was not updating. Fixed:

Select: texmaker, settings, commands, PDF viewer Select: external viewer

Then select adobe reader or whatever application you use to view PDF files.

Then you bypass the pdf viewer in the text editor altogether.




I know this question is old, but I had the same problem and found a solution for some Mac users, at least:

Short explanation: since El Capitan, the / usr / directory no longer exists, but this is where Texmaker looks for latex. In Texmaker -> Settings -> Commands, replace each / usr / expression with / Library / TeX / where Latex is installed.

This document contains all the details. https://tug.org/mactex/UpdatingForElCapitan.pdf




All Articles