Connecting Visual Studio 2013 to Firebird

While this is not a programming problem, I hope this is also the right place to ask about it.

I have problems using Firebird DB with Visual Studio.

I previously installed FirebirdClient v4.2.0.0 and DDEX v3.0.1.0, but in my project I was using the newest version of the client, and there was a mismatch when adding new models (connection in Databases window worked fine).

So, I uninstalled v4.2 and installed the newest version (, but now when I try to add a new connection:
data source selection
Visual Studio 2013 Pro crashes after entering one letter in any of the text boxes: connection editor

I tried:

  • restarting VS
  • reinstalling both FirebirdClient v.4.6.2 and DDEX v.3.0.1

but nothing helps. Anything I missed can I do to make this work?

I also downloaded some NuGet packages, but since I even tried this with a closed solution, I don't assume this is a project related issue.

Some additional notes:

  • I read about the GAC and the need to add assemblies to it, but as far as I understand, the newest versions of Firebird.Net Provider do this automatically

My specs:

  • Win 8.1 Pro
  • VS Pro 2013
  • Firebird 2.5.2
  • FB.Net Provider 4.6.2
  • DDEX 3.0.1

source to share

1 answer

I had the same problem and the solution was to remove DDEX 3.0.1 and FB.Net Provider. Remove all Firebird entries from the vendor section of the machine.config. Reinstall both and it should work again, Provider's uninstaller doesn't remove those entries, so Visual Studio crashes.

The machine configuration is under:

32-bit% Windir% \ Microsoft.NET \ Framework [version] \ Config \ machine.config


% windir% \ Microsoft.NET \ Framework64 [version] \ config \ machine.config



All Articles