How do I get IntelliJ to ignore javascript syntax errors in a single .js file?

In my IntelliJ project, I have this file:



This file contains these placeholders filled in by the servlet at runtime:

} else if(%DOMAIN_STRICT% == false) {


IntelliJ sees what %DOMAIN_STRICT%

is a syntax error that is causing it to have an angry red underline of every folder in the path to that file. Is there a way to keep intelliJ from syntax by checking this file to prevent this from happening?


source to share

2 answers

As you noted in the comments, it is obvious that these destinations are exactly what you were looking for:

To change the selection level for the current file

Open the pop-up window of the selection level by doing one of the following: From the main menu, choose Analyze | Configure ongoing file analysis. Press Ctrl + Shift + Alt + H. Click the Hector icon in the status bar. Right click the code check indicator over the scroll bar. Move the slider to one of the three available positions that determine the level of highlighting: None: Disable highlighting problems in the editor. Syntax: Select only syntax problems. Inspections: (default) highlight syntax problems and validation problems.




I use this method: - right click on the file - select "mark as plain text"

Then it checks nothing in this file. I am using this with some libs.



All Articles