Git clone: ​​no address associated with name

I know there are many questions in this question, but I found they didn't work in my case
As I am not very familiar with git I am facing the problem of cloning a repo from an openshift server. I have my ssh url for my repo (which is of the form ssh: // some_text @ my_site_url / ~ / git / my_app.git /), but when I try to clone the repo using

git clone ssh://somt_text@my_site_url/~/git/my_app.git/


I am getting the error

Cloning to "my_app" ...

ssh: Failed to resolve hostname my_site_url: no address associated with name
fatal: Failed to read from remote repository.

Make sure you have the correct permissions and the repository exists.

I am using git behind my college proxy, so I ended up installing the git proxy using

git config --global http.proxy httpProxy:port
git config --global https.proxy httpProxy:port


Please suggest if I miss any step or something is wrong.

Note. I am using OpenShift to host my project and try to access it using ssh on my local machine.


source to share

2 answers

You don't have a missing step, but it seems that you are using git behind a proxy .

Just configure your proxy properly, or even before that, make sure your proxy grants you permission to use ssh (unless you need to use any other option to use the https url).

You can even use github

instead of the standard OpenShift

git repo (as you mentioned in the comment) which will provide you with more options and of course more solutions if you run into any problem again.

See this article for more details:



I think this is enough if you are using ssh

Absolute path: git clone : /home/my_user/git/my_app.git

Relative path: git clone : git / my_app.git



All Articles