Redis service starts and stops immediately on Windows

I am trying to run Redis on Windows Server 2008

I have installed it on multiple machines and they all work fine. I've also tried many logins: admin account, local system, network service, and none of them work.

The exact message Im get:

The Redis service on Local Computer started and then stopped.
Some services stop automatically if they are not in use by other services or programs.


I also tried starting the service from the command line, but all I get is this:

[3472] 27 Jul 17:51:45.375 # Redis service failed to start.


There are no logs in EventViewer.


source to share

1 answer

Redis wouldn't start due to storage issues pointed out by Komrade P in the comments. I only had 16 GB HD and 8 GB storage. According to Redis, with 8GB of storage, you will need 24GB of free disk space.

I changed the values โ€‹โ€‹of maxheap, heapdir and maxmemory to make it work. Basically my problem is explained in the config file:

# *** There must be disk space available for this file in order for Redis 
# to launch. *** The default configuration places this file in the local 
# appdata directory. If you wish to move this file to another local disk,
# use the heapdir flag as described below.

# For instance, on a machine with 8GB of physical RAM, the max page file 
# commit with the default maxheap size will be (8)+(2*8) GB , or 24GB. The
# default page file sizing of Windows will allow for this without having 
# to reconfigure the system. Larger heap sizes are possible, but the maximum
# page file size will have to be increased accordingly.




All Articles