Failed to install Compass on RedHat 7

I am trying to install compass on RedHat 7.

I have ruby โ€‹โ€‹version 2.0.0p598 (2014-11-13) [x86_64-linux] installed.

I am running the following commands:

sudo yum insatll ruby
sudo yum install gcc gcc-c++ make automake autoconf curl-devel openssl-devel zlib-devel httpd-devel apr-devel apr-util-devel sqlite-devel
sudo gem install compass --http-proxy http://XXXXX:XXXX@XXXX:8080


I am getting the following error:

Creating your own extensions. It may take a while ... ERROR: Compass installation error: ERROR: Could not create custom gem extension.

/usr/bin/ruby -r ./siteconf20150729-6603-73q6zu.rb extconf.rb


mkmf.rb cannot find header files for ruby โ€‹โ€‹in / usr / share / include / ruby.h

extconf failed, exit code 1

Gem files will remain in / usr / local / share / gems / gems / ffi -1.9.10 for testing. Results logged in / usr / local / lib 64 / gems / ruby โ€‹โ€‹/ ffi-1.9.10 / gem_make.out

Not sure how to fix this. Before installing the compass, I even tried

sudo gem update --system


Still the same error. Then I tried updating ruby โ€‹โ€‹to 2.2.2 but still the same error. Gem version 2.0.14


source to share

1 answer

I believe you will also need yum install ruby-devel

to get ruby.h

on your system. If that's not enough, the bigger hammer approach would be to install the complete "Development Tools" packages with:

yum groupinstall 'Development Tools'




All Articles