PyCharm - cannot enter terminal window

I cannot enter a terminal window into PyCharm after upgrading to Windows 10. It might be a compatibility issue, I'm not sure. Has anyone else encountered this issue on Windows 10 and also does anyone know how to fix it?


source to share

4 answers

I solved it.

Enter cmd and open the properties dialog. Check the option: "Use legacy console (restart required)". You just need to close and open a new terminal in pycharm and it works. By doing this, you will lose the characteristics of the new Windows terminal.

Good luck!



If anyone else has this problem, I recommend using the regular Windows terminal for now, or you just need to run some tasks and then press Ctrl + Alt + R in PyCharm and use this window instead.



When creating a file to write code in pycharm, it is nothing but you open the VIM editor. Therefore, before starting to write code in the VIM editor, you need to press "i" (without the double quotation mark) in the editor window (or) paste paste which is on top of the keyboard.



Do it, it worked for me. Go to tools on the top menu bar and uncheck Vim Emulator.

enter image description here



All Articles