Eclipse does not load the plugin I am pasting in the dropins folder

I have a problem where eclipse won't load my plugin if I put it in the / dropins folder. I am using eclipse Kepler (Service release 2, aka 4.3). I already tried looking for a hint in the .metadata / .log file but couldn't find it.

Then I tried to open eclipse with:

eclipse -clean -console -consoleLog -debug /path/to/.options


Option file contains:



But the output from the console log didn't help either (the plugin is called de.jaculon.egap):

[p2] Mon Aug 03 12:33:47 CEST 2015 - [Start Level Event Dispatcher]     [reconciler]
[plan] de.jaculon.egap 2.2.6.rev5974


Information about Furter:

  • The plugin has been compiled for source compatibility "1.7".
  • Eclipse works under jdk1.7.0_51. Therefore, the plugin must be compatible.
  • The plugin is signed with javas jarsigner.exe.

I tried the same with Eclipse mars (4.5) and it works there. But currently I don't want to upgrade to 4.5 as I have multiple plugins. Also 4.5 has other bugs that I found, so this is not an option at this time.

I would be very glad for any help,

Cheers Joe


In one case, the reason was that I forgot "." in the Bundle-ClassPath directive:

Bundle-ClassPath :.


source to share

All Articles