Android Studio does not see Android processes

Sorry for my english. I am unable to attach a debugger for processing that I am running on my device.
I choose Run-> Attach debugger for Android process. Then I check Show all processes in Select process , but processes are not there. My device is correctly identified.

I also check DDMS-> Devices on Android Device Monitor . There are no processes , although my device is correctly identified, and the pie chart on the System Information tab displays information about the processor utilization for all processes in the device.

I'm trying to:

  • Restarting my Mac;
  • Restarting my device (I have a Meizu M2 note, Android 5.1 (API 22);
  • Re-enable Settings-> Developer Options-> USB Debugging on Device
  • Restarting adb by running adb kill-server and adb start-server

I am using Android Studio 1.2.2.
I read a similar post Can't connect Android Studio debugger to Android process , but my post is a bit different. I can't see processes even in DDMS.

The general problem is this: I cannot test In-app Purchasing. If I test it in debug mode on my Mac, Google Play doesn't make a purchase. But if I install an app as an alpha tester from Google Play and run it on the device, the debugger cannot see that app.
What am I doing wrong?


source to share

1 answer

It looks like cheating, but I solve my problem.

So, I open my project and go to Run-> Edit Configurations ... I create a new configuration in which they select: "Do not deploy anything" in the Package area , "Do not start Activity" in the Activity area , "USB device" in the area Target device . I acted in accordance with.
Then I select run / debug configuration, set logcats options like Log Level : "Error", find : {My own TAG}, rightmost filter : "Show only selected application".

Yes, my logs are at the error level. I still haven't resolved the issue with the spam logs. Disconnecting with help ^(?!Surface)

doesn't help, but that's another question.

Finally, I run the application on my .

Logcat still doesn't see the current process, but it displays its logs correctly.
Maybe it helps someone else.



All Articles