Is there an upper limit on model size in Mysql Workbench?

When I try to open the mwb model file, I get the following error:

error unserializing grt data 
string to long


My file is 217KB and I am using build 828 version for 64bit Windows community

The last thing I did before saving was to add some tables. Don't add long names, comments, or anything like that

There are 100 ++ tables and 10+ diagrams in the model file showing them.

Is this a bug, a corrupted model file, or is there an upper limit on the size of models?


source to share

4 answers

I got the same problem, just close and open it, it will be solved. This bug is in multiple versions



I recently ran into this error ... To fix this issue, follow these steps:

1) Close the program.

2) Find and open the MySQL Work Bench file (.mwf) using MySQL Workbench.

I learned about this from my professor, and although it seems to me that it is a bit like how I got my database table schema again.

In all fairness, this must clearly be a software bug; May I suggest downgrading your product to someone who doesn't have this error if that worries you too much?



The problem is not the size of the upper limit of the model and to solve your problem just exit MySQL Workbench and reopen it. I faced this issue with Community 64 Bit Windows version .



I ran into the same problem and searched through the internet and found a simple solution. Instead of closing the entire Workbench application and reopening it as suggested by other answers, I simply closed the "local instance of MYSQL57" and opened the .mwb file . The file is open without errors !.
It looks like this is a bug in the workbench and other users have reported it.
We hope this issue will be addressed in future releases of Workplace. Hope this help ..,



All Articles