Gensim needs a C compiler?

Sorry I don't have enough reputation to post images.

The main problem is that it tells me that I need to install the C compiler and reinstall gensim, or the train is going to be slow and it is actually very slow.

I installed mingw32, Visual Studio 2008 and added mingw32 environment variable to my path.

Any ideas on how to solve it?


source to share

3 answers

Just like you installed mingw32 and added MinGW\bin

to my variable PATH

. Then I uninstalled gensim with pip uninstall gensim

and tried reinstalling with pip install gensim

. This, however, gave the same warning, so I downloaded gensim-0.12.3.tar.gz

from here instead . I unpacked the archive as well as the internal one, opened a cmd window in the folder and ran python install

gensim to install. Now I could already see that he can see the MinGW installation. It installed correctly and I could run gensim without warning and much faster.



Similar to user1151923, after adding the MinGW\bin

path to my variable and uninstalling / reinstalling gensim via pip, I still got the same warning. I'll fix the following code to fix this issue (installed gensim from conda).

pip uninstall gensim

conda install gensim



I had the same problem and tried many solutions, but none of them worked, other than switching to gensim version 3.7.1.



All Articles